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Introduction
This document is to assist people with some of the more difficult aspects of the
SportSoftware application OE2010.
If you are unfamiliar with how to use OE2010 at the basic level should read the
manual A Beginner’s Guide to Using OE2010 before using this manual, which
assumes that people know how to use OE2010 at small OACT events.
Topics covered:
1.
2.
3.
4.
5.
6.
7.

Obtaining results for uploading to the OACT and OA web sites
Compiling results for pre-entry events (Twilight and similar events)
Using the inbuilt model events for ACT minor and badge events
Backups
Emailing the files to several recipients
Inserting did-not-start-runners (DNS) into the event
Recovering SI chip data from the log files

If you have any problems with, or suggested improvements to, this document please
direct you comments to Norm Johnston via email at
normjohnston@velocitynet.com.au
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Output of Result Files from OE2010
These instructions are to assist organisers of OACT events on how to get result files
and Archive files out of OE2010 for uploading to the OACT and OA web sites and
for archive purposes. OE2010 will handle single-days and multi-day events these
instructions can be taken to apply to single stages in the multi-day option.

Results Files to Extract from OE2010
There are several files that need to be extracted from OE2010. These files will need to
be emailed to several recipients whose addresses are shown at the end of this section.
As OE2010 resides on the event computer the above files will have to be placed onto
some type of removable media such as a USB memory stick so they can be emailed as
attachments. The identifier for a USB memory stick will be a letter other than A:
to C:, usually something like D:, E:, F:, G:, etc. In the instructions given in the
following sections all references to R:\ refer to a Removable storage device (USB
memory stick); the drive letter will depend on the computer configuration.
It is suggested that, before you start getting the files from OE2010 that you create a
folder on the R: drive that will hold all the files for your event. A folder name that
incorporates the data and event venue would be appropriate, for example:
R:\2008-10-29 Campbell Park\
could be used for the event held at Campbell Park on 29 Oct 2008. It is then a very
simple matter to Zip the entire folder and email it to the recipients.
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Result files required
•

Comma delimited (CSV) results file that is used for obtaining statistics and for
uploading to the results section of the Orienteering Australia web site. Also
used to produce results for the OACT web results and for upkeep of the event
computer archive systems.

•

OE2010 backup file that will be retained for maintenance of the OE archive
system.

•

If full electronic punching has been used in an event there are two extra files
to extract; these will be “splits” files, one in CSV format the other HTML..

•

A results text file.

All of the above files, except the Splits files, can be obtained from the same place in
OE2010. Either select Results > Official > Classes from the top menu or click on the
icon and select Results by class. That will bring up the following window:
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Set the Time format to MMM.SS and the Names to First name Surname.
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ASCII Interface (CSV) File
To output the ASCII Interface (CSV) file click on the menu item Export which will
show the following window:

Set the following options:
• File format to Character separated columns (CSV)
• Delimiter to Comma
• String Delimiter to none
• Ensure that Excel time format is ticked
Select the folder in which to save the file and enter the file name. Click OK to save
the file.
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Text File
If you want to get a text file, then on the Results window select the Publish menu
item. That will show the window:

Set the File format to TXT file (universal) then select the folder on your removable
storage device where you want to save the file and enter the file name. Click Ok when
ready to save the file.

Splits Results
If full electronic punching has been used then two extra files are required. One is a
CSV file which gets uploaded to the OA website and a HTML file which is uploaded
to the OACT web site.
Obtaining these files is almost the same as getting the files described above. On the
top menu of the main window click Results > Split times > Courses. This will show
another window:
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Click Export and follow the same instructions as given above to extract the ASCII
CSV file; name the file so that it will be recognised as the splits file.
Next click Publish to bring up the Publish Report window (see above). Select the
File format to be HTML file (WWW), and save the file as a HTML file.
Don’t forget to insert “Splits” into the file name somewhere so it can be recognised as
a “Splits” file.
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Compiling Results for Pre-Entered Minor Events
For minor events that have a large number of entrants, such as Twilight and Saturday,
most regular runners, who own their own SI chip, are pre-entered.
If this entry system is not being used then you can skip this section, but you may find
that the method of doing editing of entries of some use.
That means that the computer operator at the event has only to enter the day members
of OACT and runners who require a rented SI chip (e.g. people who have left their
own chip at home). That means that there are about 250 names pre-entered in the
computer but not all those runners will compete in each event. When setting up this
system the class that each runner would run was input on the basis of their previous
entries. Before producing the results, the compiler will have to go through the entries
and check each runner’s class.
If a person is in the entry list but did not compete, their name will not appear in the
results list. So, there is no need to delete any runner who did not compete. There are
several methods to check the results and compilers are free to use any of these
methods or to do it by any other method. Basically, it will entail going through the
entry cards and checking the class of all those that competed.
Generally the Results compiler will edit the entries after the event. Editing of entries
can only be done in the Entries > Edit window and that may make it difficult to do if
the entries are still being entered in the Entries of the day window. However, for
experienced operators, the editing could be done at the tail end of the event, probably
after entries close and the rush of entries has finished.
Entries > Edit
To check the entries click Entries > Edit and that will show all the entries. Because
you may have to modify the class of an entrant when you open the Edit window you
must set it to Pre-entry mode so that the Start no and Start time column are not
showing.
Open the Edit window by clicking on Entries > Edit to show:
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If, as shown above, the Start no and Start columns are showing then click View >
Layout: Pre entries. That will remove the Start no and Start columns to show:

The above window shows entries sorted by Class. By clicking on any column label
the entries will be sorted on that column. For example, clicking on the Surname
column will change the above window to the following:

To change an entry’s class place the cursor on that class, enter the new class, then
press Enter. The entries can be scrolled through easily using the up or down arrow
keys.
There are several ways to check the pre-entered runners. Some of these methods are:
1. Sort the entries via Start column (this is the start time). Only suitable to be
used after runners have finished their event and downloaded their chip data.
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2. Sort entry cards by course (using card colour) and sort entries by Class
3. Sort entry cards alphabetically and sort entries alphabetically.
Method 1
Open the Entries > Edit window and click View. > Layout: Entries of the day. Sort
the entries by Start (Start time) by clicking on the Start column header. We have
asked that entry card stubs be stored in chronological order. Because pre-entries will
have Start time from their chip it can be reasonably assumed that the first runners to
register will be the first runners to start. If you use this method you will have to enter
a dummy Start no or you will not be able to save the entry. Hence this method is only
suitable for use after entries have closed. N.B. this method can only be used for
runners who have finished.

Method 2
Sort the entry cards into courses (using the card colour) and then to sort the entries in
the computer by class so that each course entrant can be checked. To assist in
knowing who has entered, and you have access to a printer, a printout can be obtained
of the results and the names in the results checked against the cards by sorting the
entires by class. However, if you are working on the event computer you will not have
access to a printer so the editing may more difficult. (If you a doing the editing at
home and have access to another computer with a printer you can print results on the
event computer to a PDF file and copy that file to your home computer and print from
there.)
One advantage of using a printout is that it is relatively easy to do the checking.
OE2010 has many options for printing the results, by Class, Course, or Competitors
alphabetically. Look at the various options under Results.

Method 3
Another method may be to sort the entry cards alphabetically and to edit the entries by
sorting them by Surname.
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Formatting and Editing of Results
As results for events are to eventually be sent to Orienteering Australia’s (OA)
database for displaying on their web site and for statistical purposes it is imperative
that results be correct BEFORE the text, CSV and Archives are produced. You must
not edit the CSV file, which is the one sent to OA. Hence any editing, such as
mispunches, dnf, dns, etc., obtained after the event should be made in the OE2010
application NOT in the output file. Post event editing will entail going through the
entry cards and control punch cards to ensure that competitors were entered in the
correct course and class, and checking for mispunches, etc. Only after that has been
done should the results be produced.
Formatting OE CSV output for OACT web site
A small piece of software is available on the event laptop computers that can be used
to format the OE text files ready for upload to the OACT web site. This application is
called OE Results Format. It uses the OE csv obtained from OE2010, OE2003,
OS2003 (relay event software) or MT2003 (Multi-day software). It can be run on the
event laptops by clicking on the shortcut OE Results Format. The application has a
help file that shows how to use it. It will require you to enter event details (as shown
above) into text boxes and will reformat the input file, adding the event details and
will renumber the Team entries into the correct order.
This application will detect whether you are importing an OE2010 and, if so, you will
be asked if you want to export another CSV file in OE2003 format. You should
answer Yes to that question as the OE2003 format file is required for uploading to the
Orienteering Australia results web site.
The simplest way to use this application is to output the OE results CSV file to a new
folder, as shown above, and used OE Results Format to select that file and save the
edited file to the same folder. That folder can be on a USB memory stick if you so
choose.
If you want to install that software on your home computer you can download the
latest version by clicking the OE Results Format.zip link on the following web site:
http://www.act.orienteering.asn.au/event-management/
Instructions on the installation are given in a text file in the zip file. For most
computers the installation is very simple, only requiring the files to be placed in a
folder and a shortcut placed on the desktop. However, if your computer is running
Vista or Windows 7 the installation may be a bit more difficult.

Edit Text File
It is suggested that you use the application OE Results Format application on the
event computer to produce your results for the OACT web site. You can, however,
use Notepad to edit the OE text output file. As the OE system does not contain any
details related to event officials, etc., those details will have to be added after the text
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file has been obtained. The adding and editing of the text file will need to be done
before you email the results to recipients. You can either edit the text file using
Notepad or Word to add details that are not added by OE2010 and modify the Team
results.
If you use NotePad or Word the event details needed to be added are:
•
•
•
•
•
•
•
•
•

Venue and Date
Event Type
Organiser
Course Setter
Controller (if any)
Organising Club
Weather and Temperature
Number of Entries
Number of Participants

The number of participants is the number of people that started in the event. The
number of entries is the sum of the number of participants that started in all non-Team
classes + the number of Teams + the number that did not start (DNS). (N.B. the
number of DNS is normally only applicable to pre-entry events.)
Ensure that the date of the event, top line, is correct and not the date that the text file
was exported.
See the appendix for an example of the text file headers.
The team results will have to be edited because OE, which does not recognise teams,
assumes that participants with the same finish times have tied:
• Renumber the teams in their correct finish order
• Remove the times from all team members except the first runner in each team.
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Backups
Backups should be done after the completion of each event. If you want to copy the
event to another computer please use the backup facility, do not simply copy the event
folder. The reason for doing that is because the backup facility copies the entire event
which includes all relevant log files which are not contained in the event folder.
For general assistance and recommendations for OE backups see the relevant OE2010
help item. Unlike OE2003 that does its backups to a folder, the OE2010 system does
its backups to a single file with a skb extension. That means it easier to email this file
to another person. Also, if you use Option 2 below, OE2010 names its backups with
the event name and with the data/time appended, e.g. if the event is named
“2010Newevent2” and the date is 21 Sep 2010 and the time 16:18:26 then the backup
file name will be “2010Newevent2_20100921_161826.skb”
There are two major ways to do a backup:
1. Get OE2010 to put the backup in a folder that you stipulate, preferably on a
USB memory stick or drive, and you can name the backup as you choose. That
is the best option.
2. Let OE2010 put the backup in its own Backup folder, i.e. in the
..\SportSoftware\OE2010\Backup\ folder
To do a backup
Option 1
OE2010 can do a backup to any drive and folder by simply typing the Drive:\folder\.
The following assumes you will use a removable USB drive with the drive name R:.
From the main OE2010 window select the File > Backup menu item. That will bring
up the Backup event window that will look like the following (although the
destination drive may be different):

As you are doing the backup to another drive, such as a USB memory stick then click
on the Select file icon
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select the folder, again by using the Select file icon, that you have created on the R:
drive (in this case OE2010 backup):

Enter file name in the bottom box and press OK (there is no need to enter the skb
extension, it will be added by the system). After you press Ok the final window in this
example will be:

Press Ok to create the backup. Do not press the Create a new folder automatically
button or you will be sent back to the C: drive and you will have to start all over
again.
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Option 2
If you use this option you will have to copy the resultant SKB file to a USB removable
drive in order to email it.
For XP the backup is done to the
C:\ProgramFiles\SportSoftware\OE2010\Backup\xxx\ folder, where xxx will be a
folder name made up from the event folder name and the date/time that you do the
backup (note that the date is NOT the date of the event).
For Vista or Win 7 the backup is done in a similar manner as for XP except the folder
will be C:\SportSoftware\OE2010\Backup\xxx\ folder.
From the main OE2010 window select the File > Backup menu item. Click the
Create a new folder automatically item (see diagram on page 14). Pressing OK will
do the backup.
If you are on a Vista or Win 7 computer the above Destination drive/folder will show
C:\SportSoftware\OE2010\Backup\xxx.skb.
In order to email this backup to other people, you will have to find your way to the
relevant …\Software\OE2010\Backup\ folder and copy the relevant file to your USB
memory stick:
In XP the path will be C:\Program Files\SportSoftware\OE2010\Backup\
In Vista or Win 7 it will be C:\ SportSoftware\OE2010\Backup\
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Emailing the Results Files and Backup File
After you have the backup, results files (TXT and CSV,) they should be emailed to
several people, email addresses are given later.
The files and folder that should be emailed are:
•
•
•
•
•

File with backup of event
CSV file of results
Text file with the output from the “OE Format Results” program
Text file of results from OE2010
If a major event you should also send the Splits CSV file and the Splits HTML
file.

If you have done the backup to the C: drive you will have to transfer the backup file
on the C: drive to the USB drive folder using the Windows Explorer copy and paste
commands.
In the examples given above your USB memory stick will contain something like the
following in the R:\OE2010 backup\ folder.
Files:
OE2010 Results.csv
OE2003 Results.csv
Results.txt
Results Edited.csv
Backup.skb.
If you have all your files on your USB memory stick then all you have to do is Zip the
entire top folder using the XP or Vista facility or via WinZip.
To zip a folder using XP or Vista simply right click the folder, click Send To >
Compressed (zipped) Folder. If you are using WinZip then zip the entire folder or
folders into a single file and attach it to your email. That should reduce the attachment
to less that 10% of its original size.
The single zipped file, or all the files, should be emailed to the following addresses:
•
•
•
•
•
•
•

OACT office:
Bill Jones:
Norm Johnston:
Bob Mouatt:
Geoff Wood:
Greg Lane:
Greg Lane:
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orienteering.act@webone.com.au
bill.j@bigpond.net.au
normjohnston@velocitynet.com.au
robert.mouatt@netspeed.com.au
geoffwood@netspeed.com.au
gregory.lane@anu.edu.au and also
jodie.greg@internode.on.net (send to both addresses)
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OE2010 Set Up for OACT Minor and Badge Events
The use of OE2010 at the start of this document described the use of OE2010 for
Twilight events and said that the events for all events were pre-defined. Unless
someone gets around to pre-defining every event in OE this is not normally the case
and the event organiser may have to go through the procedure of setting up OE for
their event. To make it simpler for organisers, the event computers have pre-defined
model events for all the likely events that OACT runs. The only other events are
major ones that quite often have pre-entry and are normally set up by an experienced
organiser.

OE2010 Model Events (including Twilight pre-entry)
Each of the event computers has model events available for most OACT event types.
These model events have the Courses and Classes predefined and have the
Course/Class connections built in. The model events available are:
•
•
•
•
•
•
•
•
•

Model ACT League (extra courses) event – 6 X Red, 2 X Orange, Green, Blue
Model ACT League event – 4 X Red, 2 X Orange, Green, Blue
Model Saturday event – 2 X Orange, Green, Blue
Model Twilight event – 2 X Orange, Green, Blue
Model Wednesday event – 2 X Orange, Green by special arrangement
Model OACT MTB event Model OACT simple event (one course – 3 classes)
Model ACT Badge event – Classes only
Model Twilight Event with Pre-Entry

Note that most model events are not designed for major event such as badge or
championship events. The Model ACT Badge event is different from all the others so
will be dealt with separately.
The advantage of using the model events is that they are all consistent in their OE
database numbers, and names of clubs, courses and classes. They are also designed so
that the results will format in a consistent manner for all events, thus giving a more
professional look to the results. That applies to results on the OACT web site and the
Orienteering Australia web results.
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Design of the Model Events
OE2010 defines a course no., and a course name. The course no. is used internally but
it is normal to assign 1 to Red 1, 2 to Red 2, etc. The courses for all minor events, will
contain one or more of the following courses:
OE Database no.
1
2
3
4
5
6
7
8
9
10

Course
Red 1
Red 2
Red 3
Red 4
Red 5
Red 6
Orange 1
Orange 2
Green
Blue

Abbreviation
R1
R2
R3
R4
R5
R6
O1
O2
GR
BL

N.B. Normally OACT only offers Red courses 1 to 4 for its classic (Sunday) event;
Red 5 and/or Red 6 may be offered at special events.
For each course of the model events there are 7 Classes defined:
Class
Men: Open
Men: Junior
Men: Masters
Women: Open
W: Junior or Women Juniors
W: Masters or Women Masters
Teams

Abbreviation
MO
MJ
MM
WO
WJ
WM
Team

For classes, OE has a database number, a short name and a long name. When entering
data at events using Direct Entry the short class is selected from a drop-down box.
Except for teams the model events have the short class name for each class as a 4character name made up from the 2-letter course abbreviation plus the 2-letter class
abbreviation. The long class name is made from the course name plus the class name.
For example the following happens (here Short Class and Long Class are the OE
designation):
Course
Red 3
Orange 1
Green
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Class
Men Master
Women Open
Teams

Short Class
R3MM
O1WO
GRTeam
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Long Class
Red 3: Men: Masters
Orange 1: W: Masters
Green: Teams

Some of the class names may appear to be a little cryptic but both the Short and Long
class names within OE have a limit to their length.
All the model events have the OE2010 connection between courses and classes
predefined. It is important that you realise that, as it will have some effect if you
intend to import your course data from Corpse or OCAD. If you do not do the import
correctly you may destroy the Course/Class connection (more on this later).
Create a New Event from a Model Event
If you use these model events all that is required is to copy the relevant model event
to a new event. There are two ways to do this:
1. Invoke the Event > Copy command and create the new event during the copy.
2. Create a new event and copy the model event to the new event, this is the
safest way to do it as it precludes the possibility of overwriting an old event.
Because of the way that OE2010 names its folders the first method is recommended.
Unlike OE2003, OE2010 uses names for events and does not assign a number to the
event. Also, events are held in folder that normally has a name that reflects the name
of the event. For example, the model event “Model ACT League Event” will be held
in a folder “ModelACTLeagueEvent”, i.e. the event name without spaces between
words.
The first method uses the copy facility to create a new event and copy the relevant
model event to your new event. To do this open OE2010 and click on Event > Copy.
That will bring up the window:
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Click the Create a new event box. That will cause Copying into a new event to
show. Select the relevant model event. You must now change the Description to the
name of your event. In the above example the Description will be changed to the
name:
2010-09-21 Midweek Metro #21 Yarralumla Bays.
You will notice as you type in the new Description that the folder name will change to
reflect the event name (but without the spaces). See the example of the final window
shown on the next page.
Ensure that the All box is ticked and press Start to create the copy.
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When the copy has been completed you will be informed with a Finish window. Click
Close to close the copy window.
After you have your new event you will then have to add details of your event such as
the name of the event, date, start time, etc. Click Event > Settings to give you the
Modify event settings window:
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The Description of your event will be what you typed above. You will need to change
the Date to the event date and the Zero time to a time before your first start time. In
order to make it easy for other people, and yourself, to find the different events it is
suggested that the description be something that has the Date and Type of event and
its venue, as shown by the above example.
Next click on Settings which will bring up the “SPORTident settings” window:

Click the relevant boxes on how you are using the electronic punching; generally you
tick the boxes “Use a start station for real time start” and “Use finish station”, that
should set the Mode: to Time taking. Set “Event duration” to less than 12 hours.
Click Ok to exit.
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Course Data
This is an example of the display of what you will get for the predefined courses when
you copy the Model ACT League event:

and this is part of the corresponding Class data display:
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Unless you are going to import the course data for your event, you will have to add
some extra details about the courses manually. You will need to enter the length of
each course and its climb (optional). Note that you cannot enter the number of
controls manually, they can only be obtained by assigning controls to each course,
something that is done only for events that use full electronic punching.
If you are only using electronic punching for start and finish there is no need to enter
course data from Corpse or OCAD and it may even be detrimental if you do so. That
is because OE will expect to see all the control codes when a competitor finishes and
they won’t be there.
If you are using full electronic punching you can enter control details for each course
manually or you can import the course data from Corpse or OCAD. But, be warned,
OE does some strange things when course data is imported.
If you are going to add the courses data manually then follow the instructions in the
OE2010 help files.
Course data from Corpse and OCAD
This section deals only with the import of course data for the models of minor events;
it does not apply for major events such as badge events.
It is actually quite easy to import course data from Corpse or OCAD with a few
caveats.
Corpse and OCAD 9 and 10 and OCAD-CS will export an XML file of course data
whereas OCAD 8 only exports a text file. When you make a set of courses in Corpse
and OCAD the Course names must match exactly the course name in OE2010. For
example Red1 is not the same as Red 1. The XML file contains master data for all
controls and data for each course and, if you have entered class data, it will also be
included as part of each course data. Normally the XML file import is done into an
OE new event that does not contain any course data. If you import into a model event,
and are not careful, you could destroy the Course/Class connection. OE2010 expects
the Short class name (unlike OE2003 which expects the Long class name). And one
other complication is that the XML file has a Course ID number, and it is highly
unlikely that the ID number will match the OE course database number. To get
around these problems the following is suggested:
An example of the course section of an XML export from Corpse is shown below:
<Course>
<CourseName> Orange 1 </CourseName>
<CourseId> 1 </CourseId>
<ClassShortName> O1MO;O1MJ;O1MM;O1WO </ClassShortName>
<CourseVariation>
<CourseVariationId> 0 </CourseVariationId>
<CourseLength> 4960 </CourseLength>
<CourseClimb> </CourseClimb>
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<StartPointCode> s1 </StartPointCode>
<CourseControl>
A similar thing will appear for all courses. To make this file suitable for use in an
event copied from a model event simply use Notepad to remove the lines that contain
the CourseID and ClassShortName:
<CourseId> 1 </CourseId>
<ClassShortName> O1MO;O1MJ;O1MM;O1WO </ClassShortName>
Do that for all courses.
If you do that then OE will use the CourseName to match up with the same course
name in its database and your courses will import correctly and the Course/Class
connection will remain intact.
Using this method means that the class names that are used in Corpse or OCAD are
not used by OE and so there is no need to bother putting the class data on the Corpse
or OCAD courses.
Importing Courses into a Model Event
After you have edited the XML file as above you are now ready to import the courses
data into OE. Because the model events, other than ACT Badge events, already have
the Courses and Classes, and their connections, defined, when you import the courses
you must ensure that you don’t wreck the connection or wipe out the courses. To do
the import, go to the main OE2010 window and click Courses > Import Courses.
That will give the window:
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Set the Courses selection to Update existing only, Controls to Clear and create
again, Identify courses by Description and File format to XML. Select the relevant
XML file for import and click on the Ok button. After the import has finished you
will get a window that shows a report of the import. It will more than likely say that it
found unknown classes; that can be ignored. Hopefully there will be no errors. If there
is any inconsistency between the course names in OE and the XMP file then you will
get an error.
After you import your courses it is imperative that you obtain a report from OE of
your courses and classes to ensure that all is as it should be. To do that click on
Courses > Reports and get a text output file. Do the same for your classes. The text
output file should be sent to the event Controller for checking.
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ACT Badge Events
This section covers the set up for Badge and Major ACT events. These events will
probably be pre-entry and use computer based entry via the OACT web site. Hence
the entries will be able to be imported into the OE system thus requiring manual entry
only for Enter-on-the-day (EOD) participants.
Classes
As the courses for major events are set according to the type of event, which may be
Sprint, Middle or Long Distance, the classes that are used may vary considerably.
Sometimes classes may be combined if not enough people enter for a particular class.
The model event has badge classes only defined, no courses. All you have to do
initially for a major event is decide what classes are to be used. The model event
contains all the classes that should be required, it is a very simple matter to delete
those that are not required, or add more if they are required.
When designing the nomenclature used for the badge classes a couple of things were
done:
1. OE outputs its class results in the order that they appear in the OE internal
database not alphabetically.
2. The long class names are set so that the Orienteering Australia web results
system will calculate the badge credits for the A, AS and B courses. That
means that there must be no spaces in the long class names. For example you
must have “MOpenB” not “M Open B”, etc.
If you decide to add some other class not in the model event you must obey those
rules for A, AS and B classes; eg. M45B, not M45 B.
Courses
Because the courses are not defined in the model events you have a lot of flexibility in
what you call them. That applies whether you are entering the course data manually or
importing from a file. It is up to you to define what course is to go with each class. If
you are entering the course data manually you will have to define the course/class
connection manually. If you are importing your courses from Corpse or OCAD the
Course/Class connection will be made in the import process, assuming you do it
correctly.
N.B. If you want the Course/Class connection to be made when you import your
courses you must use an XML file. Corpse only outputs an XML, OCAD 8 only
exports a text file and OCAD 9, 10 and CS will export an XML and a text file.
However, OE will only define Course/Class connections with an XML file. Also, the
Class names used in Corpse or OCAD must be the same as the Short Class name that
are used in OE2010.
If you are entering your courses manually it is preferable to enter them in order of
difficulty, i.e. Red 1, Red 2, etc., so that, when the final reports are produced that is
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the order that they will print. If you are entering the courses data from OCAD or
Corpse you should ask the person who is producing the maps to try to ensure that the
courses output in the order Red 1, Red 2, down to Green then Blue, or Course 1,
Course 2, etc., if that is the nomenclature. The reason that this is required for badge
and major events, and not minor events is that, unlike in minor events, OE uses the
CourseID to define its internal database number and that defines the course order. OE
outputs its reports in the order of its database number, not alphabetically.
An example of part of a XML file for a recent badge event is shown below:
<Course>
<CourseName> Red2/3 </CourseName>
<CourseId> 2 </CourseId>
<ClassShortName> M20A </ClassShortName>
<ClassShortName> W21A </ClassShortName>
<ClassShortName> M35A </ClassShortName>
<ClassShortName> M45A </ClassShortName>
<CourseVariation>
N.B. You do not have to edit anything out of these files.
Because the Badge model event has no courses defined do the import of the courses
as explained above for minor event only this time you must select Clear and create
again for the option under Courses.
After importing your courses you should check for any errors in the Import window.
Any class errors will show up there and, if there were any differences between the OE
classes and XML classes, the errors will be picked up at that point. If you get an error
in the classes it is more than likely because the class name in the import file is not the
same as that in OE2010. The easiest way to fix it is to simply edit the XML file with
Notepad and make the relevant class match exactly that in OE.
But, and this is very important, if you are using OE2010 then, unlike OE2003,
the lines similar to <ClassShortName> M20A </ ClassShortName> are now
correctly named. When this file is imported, OE2010 will look at the Short Class
name. Also, the class in those lines must appear exactly as the Short Class is
shown in OE2010. (N.B. OE20003 requires the Long Class name in the above
XML file lines.)
Again, after importing courses you must get a text file printout and check carefully
that you have everything correct. Send the text files to the Controller for doublechecking.
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Did Not Start Runners
At some events, mainly those in which competitors have pre-entered, it is important
that the organisers keep track of people that have started their course. This can be
done manually be having someone check names off the start list. That requires
someone to manually go through the list and set non-starters to dns in OE2010 (in the
Evaluate Chips window). This can be quite difficult especially if you have several
starts (for different courses). Also, if you happen to be using more than one server
(master) computer at a major event you would have to enter the DNS runners into
every server computer.
A simpler method is preferably to use the Check SI units to see who has started their
course. This method will work for multiple Check stations. You can also use the Start
units but you should not use both types at the same time. It is a good idea to have a
person at the entrance to the start area with a Check station; all runners can insert their
chip into the Check station as their name is checked off.
You should wait until all starts have sent off their last runners and you have all the
Check stations at the computer. Get a Check station and connect it to the computer
Master unit via the inductive coupling stick. If you are only using one computer and
one Master unit then you will have to shut down the Read Chips window. If you are
using a network then this operation can be done on the Server with little impact on the
Client (Remote) computers.
If you are doing this with a Multi-day event is imperative that the correct stage is
selected otherwise you may wipe out the data for other stages.
On the top-level menu click on Competition day > Evaluate SI stations which will
give the window:

If you have not accessed this window previously for this event then it should be
empty.
Click Actions > Download punches (or click the relevant tool) which should show
the following window:
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If you are using two Master stations you may have to ensure that you are accessing
the COM port not in use by the Read Chips system. Click COM port and choose the
correct port. Place the Check SI station on the Master, and make sure Master is
showing in the box on the right. Click Download. The green lamp should change to a
Magenta colour that indicates it is reading the Check SI station. The time taken to
read the station will depend on much data it contains.
As it is being read the number of chips read will show in the box at the bottom of the
above window. Chip data will show in the Evaluate SI stations window. If you have
other Check stations to read then do the above with them. When all Check units have
been read click Close. That will take you back to the Evaluate SI stations window,
which, will show the data for all the SI chips that were read.
In the Evaluate SI stations window click Actions > Not started competitors which
will cause the Find competitors who did not start window to pop up. Check the
boxes for the Stations to be computes (in this case Check stations):
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Use the Select/deselect all button at the bottom so that all runners are selected. Click
the Start button and that will set any runners who did not punch the check station to
DNS. That will change the above window to show the SI stations read and also
anyone who did not start. If oyu want to set the names shown to DNS then slick Yes
in the pop-up box.

You can check the Evaluate chips window to see if the operation has worked.
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OE2010 and MT2002 Recovering Results from Log File
The need to recover SI times from the silog files may be required for several reasons:
•
•
•

To recover a runner whose results were overwritten accidentally by the
computer operator
To rebuild the results
To copy the SI times to the same event on another computer

OE2010 writes its silog file when the chips are read. The silog file folders are created
when the event is created and will have the same name as the event folder, but will be
empty, except for headers, until the first chip is read. If you are working in a network
the log files on the remote computers will have “_R” appended to the log file folder
name. Also, silog files are written on the computer that reads the chips. If you are
operating with a network only those computers that are downloading chips will have
silog files; that may only be the Client (Remote) computers.
The log folders are kept in the C:\SportSoftware\OE2010\Logs\ folder. When you do
a backup of an event the relevant silog folder is added to the backup folder.
To copy the results from one event into another, perhaps on another computer, do the
following:
Identify the silog folder for the event to be copied and copy it from the silog folder on
the computer with the results to the silog folder on the computer without the results
Assuming you have the entries in the second computer then follow the instruction
given above to recover the chip data.
If you are using a network and want to rebuild the chip data on the Server (Master)
computer you will have to gather all the silog files from the Client (Remote)
computers and transfer them to the Server (Master) computer. Please remember
though, if you are using more than one client (remote) computer the silog files may
have the same name on each client. You will have to work out some way to
differentiate the silog file from each client PC. The OE2010 help files covers this
matter.
To recover data from the log files click on the main window option Competition day
> Log files. This operation has many options so, if you need to use it, it is suggested
that you look at the relevant OE2010 help file.

21/06/11

34

Appendix
Text File Header
Below is an example of the header that should appear on the text file output for text
files that get uploaded to the OACT web site:.
Campbell Park on Wed 29 Oct 2008
Twilight #3
Organiser: Bill Jones
Course setter: Shannon Jones
Controller: optional
Club: Red Roos
Weather: Cool
Temperature: 17°
Entries: 143
Participants: 168
Comments: optional
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Computers: What to do before, at and after an event
To assist yourself and others who have to use the equipment after you the following
tasks should be done:
Before an event:
• Check all the equipment required is in the wood and plastic computer boxes;
use the inventory sheets to check.
• Ensure computer battery is fully charged at home – this will save the battery
power pack or car battery going flat at the event.
• If the battery power pack is to be used then ensure it is fully charged, this may
take two days or more.
• If using full SportIdent then ensure that you have loaded in the course data
either manually or via XML file, it will be too late on the day to do it.
At Event
• Plug the computer power adapter into the inverter and connect the inverter to
either the battery power pack or to a car battery; see computer set-up sheet in
wood box. Turn the inverter on before turning the computer on.
• If the inverter low voltage alarm comes on during the event then turn off the
inverter before you either change to another battery power pack or turn on
your car engine. Then turn the inverter back on.
• Do not run the computer on its internal battery unless either the battery power
pack or car battery has gone flat.
After an event:
• Ensure that SI units, Start, Finish, Clear, Check have been turned off (use the
purple key)
• Do a backup of the event to a USB memory stick
• Check that all the correct equipment is in the wood and plastic boxes; use the
inventory sheets to check
• Finalise the results either at the event or at home.
• Email results and backup files to the names listed in the manual
• If possible ensure that the Lenovo laptop computer battery is fully charged
• If possible, and you have been using the battery power pack, ensure that it is
fully charged
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Lenovo Battery Performance
Below is a graph that explains very clearly why it is imperative to have the Lenovo
laptop battery fully charged before an event. The current drawn during the charging
cycle when the battery is less than 95% capacity is very high and will very quickly
flatten the battery power pack or car battery.
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Other Resources
Other websites that have some excellent documentation on how to use OE2010,
OS2003 and MT2003 are.:
http://www.orienteering.asn.au/technical/SPORTidentInfo/
http://uringa.nsw.orienteering.asn.au/sportident%20manual/sportidentpage.htm
http://www.sportsoftware.de/eng/olsw.htm
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